While we strive to provide our customers with 24/7 access to superior location intelligence, on the rare occasion we do experience an unexpected outage, we’ll update this page with a description of what’s happening. Please subscribe to receive updates.

Help Center Service Disruption

Incident Report for Nearmap Status Page

Resolved

This incident has been resolved.
Posted May 12, 2025 - 23:49 AEST

Update

We are continuing to investigate this issue.
Posted May 12, 2025 - 17:17 AEST

Investigating

We are investigating an issue affecting our Help Center, https://help.nearmap.com/. The service is currently unavailable. We will provide updates about the status of this issue as and when information becomes available.
Posted May 12, 2025 - 17:00 AEST
This incident affected: Product Documentation.