While we strive to provide our customers with 24/7 access to superior location intelligence, on the rare occasion we do experience an unexpected outage, we’ll update this page with a description of what’s happening. Please subscribe to receive updates.
Betterview Platform Monitoring
Incident Report for Nearmap Status Page
Resolved
The issue with the Betterview Platform has been resolved.
If you experience any issue accessing the Betterview Platform, please click here to raise a support ticket.
Posted Nov 12, 2024 - 14:38 AEDT
Update
We are continuing to monitor for any further issues.
Posted Nov 12, 2024 - 14:20 AEDT
Update
We are continuing to monitor for any further issues.
Posted Nov 12, 2024 - 13:36 AEDT
Monitoring
We have identified an issue with the Betterview Platform and a fix has been deployed and is being monitored.
If you experience any issues accessing the Betterview Platform, please click here to raise a support ticket.
Posted Nov 12, 2024 - 13:30 AEDT
This incident affected: Betterview Platform - Client Portal.