While we strive to provide our customers with 24/7 access to superior location intelligence, on the rare occasion we do experience an unexpected outage, we’ll update this page with a description of what’s happening. Please subscribe to receive updates.

Betterview Platform Disruption

Incident Report for Nearmap Status Page

Resolved

This incident has been resolved.
Posted Apr 27, 2025 - 10:44 AEST

Investigating

We are currently investigating an issue affecting the Betterview Platform, our web-based application. Users may experience temporary slowness while processing orders. We will provide updates about the status of this issue as and when information becomes available.
Posted Apr 27, 2025 - 09:47 AEST
This incident affected: Betterview Platform - Client Portal.