While we strive to provide our customers with 24/7 access to superior location intelligence, on the rare occasion we do experience an unexpected outage, we’ll update this page with a description of what’s happening. Please subscribe to receive updates.

Service Investigation - Nearmap AI Services

Incident Report for Nearmap Status Page

Resolved

The issue affecting the Nearmap AI and Coverage service has been resolved. If you experience any issue with Nearmap services, please click here to raise a support ticket.
Posted Jun 11, 2025 - 09:49 AEST

Monitoring

The Nearmap AI and Coverage services have been restored and are being monitored. If you experience any issue with Nearmap services, please click here to raise a support ticket.
Posted Jun 10, 2025 - 18:12 AEST

Investigating

We are currently investigating an issue affecting Nearmap AI services and operating at degraded performance. We will provide updates about the restoration of these services as soon as information becomes available.
Posted Jun 10, 2025 - 16:19 AEST
This incident affected: MapBrowser, Betterview Platform - Client Portal and API (AI Feature API, Transactional API, Betterview Insights API).