While we strive to provide our customers with 24/7 access to superior location intelligence, on the rare occasion we do experience an unexpected outage, we’ll update this page with a description of what’s happening. Please subscribe to receive updates.
MyAccount Service Disruption
Incident Report for Nearmap Status Page
Resolved
This incident has been resolved.
Posted Nov 04, 2023 - 05:11 AEDT
Investigating
We are investigating an issue with the MyAccount self-service portal and Nearmap MapBrowser where these services won't load on certain machines. We will provide updates about the status of this issue as and when information becomes available.
Posted Nov 04, 2023 - 04:45 AEDT
This incident affected: MapBrowser and MyAccount.